F250 not starting after cleaning battery posts

Discussion in 'F-250 and F-350 General Tech and Info' started by nast70, Jan 13, 2018.

  1. nast70

    nast70 Junior Member

    Age:
    48
    Posts:
    8
    Likes Received:
    0
    Joined:
    Mar 28, 2014
    Took my truck for a spin today. Radio and heater stopped working a few minutes in then all lights on the dash went out. Pulled over and one of the cables on the + had corroded off. Manged to get home and clean the posts. Charged the battery but she won't turn over. Makes lots of noise in side, cd player shuffles, dash beeps just random stuff.
    I just used baking soda and water on the posts and a couple machine bolts to replace the corroded ones but something is still wrong. Any thoughts?

    Sent from my SM-N900W8 using Tapatalk
     
  2. nast70

    nast70 Junior Member

    Age:
    48
    Posts:
    8
    Likes Received:
    0
    Joined:
    Mar 28, 2014
    Its a 2009 F250 with the 5.4L btw.

    Sent from my SM-N900W8 using Tapatalk
     
  3. Roush PSD Interceptor

    Roush PSD Interceptor Straight Piped Diesel Staff Member

    Age:
    53
    Posts:
    9,392
    Likes Received:
    491
    Joined:
    Nov 28, 2010
    Location:
    Ringgold, Georgia
    How about cleaning the posts and insides of the post clamps with a terminal cleaner brush?

    You need clean lead to lead contact to send full amperage through the cable to the starter.

    Sent from my SM-G930P using Tapatalk
     

Share This Page