Fuses clicking and no blinkers when headlights are on

Discussion in 'Audio & Electronics' started by Dawgfan54, Dec 14, 2013.

  1. Dawgfan54

    Dawgfan54 Full Access Member

    Posts:
    529
    Likes Received:
    4
    Joined:
    Nov 30, 2010
    Location:
    Georgia
    Alright guys I can't locate this problem, when I hit the brake I hear a click coming from the fuse box in the passenger side footwell. I thought this was related some how to my doing the "Bambi mod" but I took the Bambi mod off and it still clicks. Go figure.

    I also have a problem where my blinkers won't come on and make an annoying buzzing sound (as If I have no bulb in) when I have my headlights on.
    When the headlights are off the blinkers work fine. Now they do the hyper flash normally, but that's because I have led bulbs In my blinkers.
    And I just haven't gotten around to buying resistors to make them flash normally.

    I don't know if it would help but I have HID's in my fogs and headlights.
    I hope y'all have a better idea as to what's the problem than I do.
    Thanks for the help



    Sent from my iPhone using Tapatalk
     
  2. Ak 08 stx

    Ak 08 stx The Only One

    Age:
    30
    Posts:
    7,532
    Likes Received:
    243
    Joined:
    Nov 28, 2010
    Location:
    North Pole, ALASKA
    ok as far as the blinkers, you can either get the resistors and splice and dice and have it like that, but if you don't want to splice and dice the wires you can get the led flasher and replace it with the original flasher. now the flasher is ep-27L, L meaning its for led lights and that just goes were the original flasher goes
     
  3. Dawgfan54

    Dawgfan54 Full Access Member

    Posts:
    529
    Likes Received:
    4
    Joined:
    Nov 30, 2010
    Location:
    Georgia
    Okay but would that explain the clicking I hear when I hit my brake pedal?
    And the error the blinkers have only when my headlights are on?


    Sent from my iPhone using Tapatalk
     
  4. ak_cowboy

    ak_cowboy Penguin Hunter

    Age:
    32
    Posts:
    14,720
    Likes Received:
    259
    Joined:
    Nov 28, 2010
    Location:
    Alaska
    That is strange. It might be the combo of LEDs and HIDs interfering somehow. I would replace the Flasher relay first and see if that helps.
     
  5. cowboy

    cowboy Sheriff Staff Member

    Posts:
    9,623
    Likes Received:
    64
    Joined:
    Nov 30, 2010
    Location:
    Lebanon, ohio
    agree with Will. Or if you still have the old bulb's throw them in there just to see if the clicking goes away.
     

Share This Page