Sub question...need help!!!

Discussion in 'Audio & Electronics' started by hgray, Oct 5, 2013.

  1. hgray

    hgray Junior Member

    Posts:
    5
    Likes Received:
    0
    Joined:
    Oct 5, 2013
    Hello all...this is my first post.
    I just bought an 05 f150 fx4 lariat
    1st thing...I put a CD player in it..turned it on & it wasn't all that loud...found out there was the 8" sub under the back seat.. It's not working. I checked all my wiring..seems to be good
    Checked fuses...they seemed to be good
    Sooo...I need help to figure out why the sub isn't working???
    What am I missing?
    Thanks


    Athens Staff
     
  2. Roush PSD Interceptor

    Roush PSD Interceptor Straight Piped Diesel Staff Member

    Age:
    54
    Posts:
    9,566
    Likes Received:
    503
    Joined:
    Nov 28, 2010
    Location:
    Ringgold, Georgia
    :welcome: hgray
    Post up a new thread about yourself in the intro section.
    http://www.fordfullsize.com/forum/f6/

    Check fuses/power to the amp.
    Check remote turn on wire (usually solid blue) from radio to amp.
    Sub wiring correctly connected to amp.
    Test sub, connect C or D cell flashlight battery momentarily across
    speaker wires, if popping sound happens, sub is good.
    RCA cables connected to back of in dash radio head unit.
    Sub is turned on in dash radio head unit menu selection.

    If all these check good and still no sound amp may be fried.
     
    Last edited: Oct 5, 2013
  3. hgray

    hgray Junior Member

    Posts:
    5
    Likes Received:
    0
    Joined:
    Oct 5, 2013
    I'm not sure there is suppose to be RCA wires
    It's the factory sub that comes with the audiophile package
    It's a a hard plastic box under back seat
    Fuses are good
    I'm lost


    Athens Staff
     
  4. Roush PSD Interceptor

    Roush PSD Interceptor Straight Piped Diesel Staff Member

    Age:
    54
    Posts:
    9,566
    Likes Received:
    503
    Joined:
    Nov 28, 2010
    Location:
    Ringgold, Georgia
    Last edited: Oct 5, 2013
  5. hgray

    hgray Junior Member

    Posts:
    5
    Likes Received:
    0
    Joined:
    Oct 5, 2013
    Ok..cool
    I found that part
    Now..dumb question
    Where does that part go
    Behind CD player?


    Athens Staff
     
  6. Roush PSD Interceptor

    Roush PSD Interceptor Straight Piped Diesel Staff Member

    Age:
    54
    Posts:
    9,566
    Likes Received:
    503
    Joined:
    Nov 28, 2010
    Location:
    Ringgold, Georgia
    I'd say the easiest would be at the amp
    just allowing for air circulation around it.
     
  7. Roush PSD Interceptor

    Roush PSD Interceptor Straight Piped Diesel Staff Member

    Age:
    54
    Posts:
    9,566
    Likes Received:
    503
    Joined:
    Nov 28, 2010
    Location:
    Ringgold, Georgia
    Last edited: Oct 5, 2013
  8. hgray

    hgray Junior Member

    Posts:
    5
    Likes Received:
    0
    Joined:
    Oct 5, 2013
    No..it didn't
    Apparently that's what I need?
    Do I still need the 12v to 5v regulator?


    Athens Staff
     
  9. hgray

    hgray Junior Member

    Posts:
    5
    Likes Received:
    0
    Joined:
    Oct 5, 2013
    Ok I found the parts I need
    Just hoping the 12 to 5v step down comes with good instructions
    I have no clue on where to hook that one up too
    Thanks of your help


    Athens Staff
     
  10. Roush PSD Interceptor

    Roush PSD Interceptor Straight Piped Diesel Staff Member

    Age:
    54
    Posts:
    9,566
    Likes Received:
    503
    Joined:
    Nov 28, 2010
    Location:
    Ringgold, Georgia
    Sorry for the misunderstanding.
    Been a long last few weeks for me.

    Seems the 12v to 5v was only for sub popping sound
    your problem is no output from the amp/sub.
    I'd try looking at the 8 pin amplifier harness first.
     

Share This Page